After upgrading from 1.6 to 1.7.3 your unable to access the DC/OS UI

 

Symptoms

After upgrading from 1.6 to 1.7.3 you are not able to launch DC/OS UI

 

Steps taken to resolve

Using  

systemctl list-units| grep dcos

you may see a problem with "dcos-gunicorn-bouncer.service" it is not getting started.

It appears as 

jdcos-gunicorn-bouncer.service       loaded     activating

 

You see an error in the journalctl log

Process: 12547 ExecStart=/opt/mesosphere/packages/bouncer--415369472893c05b041e9003ee9b672cfc12a70e/bouncer/bin/bouncer-gunicorn.sh (code=exited, status=2'''

 

Reviewing the bouncer json,

/opt/mesosphere/etc/bouncer-config.json

 & using a jsonlint, here http://jsonlint.com/ showed it was invalid.

 

We figured out that the bouncer-config.json was formatted incorrectly due to a typo in the creation of the DC/OS 1.8 config.yaml

TRUE

should have been 

true

Reference: https://docs.mesosphere.com/1.7/administration/installing/custom/cli/ Section: "Create configuration file"

Result

The DC/OS UI became available after executing 

sed 's/True/true/g' /opt/mesosphere/etc/bouncer-config.json




Have more questions? Submit a request

Comments

Powered by Zendesk